Crash dans l'établi d'armure

Tout ce qui tourne autour de Fallout 4 mais qui n'est pas lié aux traductions de la Confrérie.
Avatar du membre
Blazckowicz
Confrère
Messages : 3

Crash dans l'établi d'armure

Message par Blazckowicz »

Depuis plusieurs jours j'essaye de résoudre un problème de CTD avec l'établi d'armure d'AWKCR.

j'ai mis le mod en question à jour avec la version de la confrérie (8.6.0) et appliqué les corrections que j'ai trouvé à cette page : https://www.nexusmods.com/fallout4/articles/1463# ( y compris celle de Yopoman) et rien à faire le crash continu et ce malgré l'installation de VIS-G, DEF_UI et Buffout 4. De même j'ai lancé Loot et FO4Edit pour nettoyer les plugins et l'ordre de chargement et veillé à ce qu'il n'y ait pas plus de 255 ESP d'activé ( 246 au total sans compter les ESL). J'ai également installé ce mod (: https://www.nexusmods.com/fallout4/mods/22402) qui n'a malheureusement rien résolu.

Si j'ai bien compris cela pourrait venir de mots-clé d'armures défectueux qui ferait planter le jeu.

En revanche ce qui me semble singulier c'est que le CTD n'arrive pas tout de suite lorsque j'ouvre l'établi d'armure, il survient toujours au bout de la 2 ou 4e fois que je l'ouvre et que je fais défiler les armures de mon inventaire parfois du premier coup juste après une sauvegarde rapide.

Qu'en pensez-vous ?

Avatar du membre
Bran ar Kamalar
Moddeur en herbe
Moddeur en herbe
Messages : 2701

Re: Crash dans l'établi d'armure

Message par Bran ar Kamalar »

il faut savoir que le jeu ne crash pas immédiatement, il lui faut en général quelques seconde voir quelques minutes pour le faire. La raison est simple il cherche un fichier qui normalement devrait contenir toutes les causes de crash, et comme il ne le trouve pas il doit en faire un. A noter que si ce fichier pourrait être une aide importante, il est totalement inaccessible. Si tu ouvres le ck avec tes mods, il se créera un fichier warning qui te montrera toutes les sources de bug possible. Note que si tu charge que le jeu de base avec les dlc et sans le pno ce fichier aura beaucoup d'entrées.
C'est le seul moyen d'obtenir ce fichier.

Tu as bien mis AWKCR qui se trouve sur la confrérie ?

Si tu as des bug à ce niveau sans mettre les mods qui devraient corriger les bugs, faut que tu cherches dans tes mod d'arme et armure ce qui pourrait poser problème. Le plus simple, tu les enlèves tous et tu refais une partie.
Puis tu les ajoutes par groupe de trois. Tu verra ainsi lequel provoque le bug.

Il y a aussi wyre bash qui peut te donner des infos, soit lancé, soit dans son journal de debug (il en crée un s'il constate des bugs)

Loot peut aussi donner des infos si le mod est considéré comme obsolète et qu'il ne fonctionnera pas sur cette version de jeu.

Il me semble que def-ui peut poser des problèmes je ne l'utilise pas.

L'ordre de chargement tu dois le faire à la main car celui de LOOT c'est du gros n'importe quoi. Globalement il arrive à ranger correctement les quelques mod qu'il connait (tu peux les compter sur les doigts d'une main) et tout le reste il met en vrac dans le dossier par défaut. LOOT sur ce jeu ne sert à donner des indications sur les mods. Je l'utilise car j'ai totalement refait un nouvel ordre de chargement et je classe moi-même dans les bon dossiers.

Vas voir les explications et l'ordre de chargement des mod ici : Load order survival guide
Ok il est en anglais mais si moi j'ai pu le comprendre tout le monde peut le comprendre vu mon niveau d'anglais.

J'en ai tiré un ordre de chargement qui fonctionne très bien, je pourrais te le transmettre car je n'ai fais que reprendre les catégories mentionnées dans ce document, mais je préfèrerai que tu lises les explications.
Image

"Je ne crois pas à l'astrologie.
Je suis sagittaire et comme tous les sagittaires, c'est dans ma nature d'être sceptique."
"Toute technologie suffisamment avancée est indiscernable de la magie."
Arthur C. Clark

Avatar du membre
Blazckowicz
Confrère
Messages : 3

Re: Crash dans l'établi d'armure

Message par Blazckowicz »

Merci de ta réponse !

j'ai trouvé une solution avant hier en installant le patch de VIS-G pour AWKCR et depuis plus de crash dans l'établi ( https://www.nexusmods.com/fallout4/mods/40666).

Par précaution je vais quand même aller consulter le Load order survival guide pour que mon ordre de chargement soit propre.

Merci du coup de main :fo_up:

Avatar du membre
Bran ar Kamalar
Moddeur en herbe
Moddeur en herbe
Messages : 2701

Re: Crash dans l'établi d'armure

Message par Bran ar Kamalar »

De rien.

Avant de trouver ce document j'ai beaucoup galéré. Depuis j'en parle à tout le monde.
Image

"Je ne crois pas à l'astrologie.
Je suis sagittaire et comme tous les sagittaires, c'est dans ma nature d'être sceptique."
"Toute technologie suffisamment avancée est indiscernable de la magie."
Arthur C. Clark

Avatar du membre
Picsou
Confrère
Messages : 194

Re: Crash dans l'établi d'armure

Message par Picsou »

C'est pas un fichier "warning" mais "editorwarning" qui est créer en ouvrent un mod contenu dans mo2 ou le dossier data du jeu avec le ck.
Le fichier est créer au même endroit que f4se ou le lanceur du jeu.
Après une fois un bug résolut j'efface le dossier.
Teste que tout est normal avec un re fichier.
C'est le meilleur moyen pour rendre le jeu propre sans aucun bug.

Mais il ne règle pas du tout le rangement des mods pour rendre le jeu normal sans ralentissements ou bug en cause d'un mauvais rangement entre les dépendances et importance pour chaque mod.

Retourner vers « Aide »